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MIM Target Recepient Limitations - Support and Troubleshooting
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KB0993881

MIM Target Recepient Limitations


526 Views Last updated : Apr 20, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

1) Entering over 4000 Users in the 'Initial End User Communication' section of an email client template will cause the below error to occur.  A best practice is needed to workaround this issue.

'4000 users were retrieved for sending Email per the maximum limit set by Admin.'

 

2) How to best utilize BCC field instead of the TO field?

 

Cause

1) The current system limitation is 4k direct emails. The suggestion here is to identify email distribution lists instead and add them to the Groups.

Resolution

1) These are the steps you can follow as a workaround to return distribution lists instead of member emails:

-In Script Include - CommunicationManagementUtilSNC._getContactsForEmail this returns the list of participants. Override this in CommunicationManagementUtil._getContactsForEmail change the implementation for groups to return the group email instead.

 

2) Regarding Using BCC in place of TO

This is not supported OOB (out of box) yet and being added in a future release. These are the steps you can follow as a workaround:
- /nav_to.do?uri=%2Fsys_email_client_configuration_list.do -> Define a configuration for Incident Communication Task Table and mark 'To is Optional' as true (See screenshot). This step is for Email client to allow sending without 'To' populated.

In Script Include - CommunicationManagementUtilSNC._getContactsForEmail this returns the list of participants. Override this in CommunicationManagementUtil._getContactsForEmail . Return empty string.


- In CommunicationManagementUtil define _getContactsForEmailCustom with the OOB definition so that it lists the values it used to.


- Open the Email Client Template that we referred from (Communication Plan Definition > Communication Task Definition > Email Channel Definition). In the BCC filed add - javascript: new sn_comm_management.CommunicationManagementUtil define _getContactsForEmailCustom. If we didn't add an Email Template in the related channel - /nav_to.do?uri=sys_email_client_template.do?sys_id=e87ea60987a013000e3dd61e36cb0bbe will be used, so update this instead.


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