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Cyberark integration fails with unauthorized errors. - Support and Troubleshooting
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  • Cyberark integration fails with unauthorized errors.
KB0870533

Cyberark integration fails with unauthorized errors.


2473 Views Last updated : Apr 10, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

CyberArk Integration is failing with below errors in the agent logs:

2021-01-12 05:17:12 (494) Worker-Interactive:CommandPipeline-132c57131b21a4109da17599cc4bcbe6 SEVERE * ERROR The specified credential 'CORPDEV-SVC-WINAUTO' does not exist in the specified vault. Specific Error: APPAP133E Failed to verify application authentication data: IP "MID_Server_IP'; MID_Name;MID_FQDN" is unauthorized

2021-01-12 05:17:12 (494) Worker-Interactive:CommandPipeline-132c57131b21a4109da17599cc4bcbe6 SEVERE ERROR The specified credential 'CORPDEV-SVC-WINAUTO' does not exist in the specified vault. Specific Error: APPAP133E Failed to verify application authentication data: IP "MID_Server_IP'; MID_Name;MID_FQDN"  is unauthorized

2021-01-12 05:17:12 (494) Worker-Interactive:CommandPipeline-132c57131b21a4109da17599cc4bcbe6 SEVERE ERROR * Problem with client's CredentialResolver: Problem resolving the credential:

Release

All Versions.

Cause

CyberArk is not configured properly for MID server integration/Authentication.

Resolution

1. Follow the CyberArk integration configuration documentation to configure the integration.

2. The error message indicates that the MID server is not getting authenticated at the CyberArk end.

SEVERE * ERROR The specified credential 'CORPDEV-SVC-WINAUTO' does not exist in the specified vault. Specific Error: APPAP133E Failed to verify application authentication data: IP "MID_Server_IP'; MID_Name;MID_FQDN" is unauthorized

3. Configure the APPID "ServiceNow_MID_Server" on the CyberArk Side(This AppID is the default one and can be changed in config.xml file with the parameter ext.cred.app_id).

4. Also, make sure that the MID server in question is added in to the allowed machines list on CyberArk Side.

5. After making the changes on the CyberArk Side, re-run the discovery or "test credentials" and it should work good after that.


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