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SEVERE *** ERROR *** Unknown credential type downloaded; MID server may not have access to credentials table - Support and Troubleshooting
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  • SEVERE *** ERROR *** Unknown credential type downloaded; MID server may not have access to credentials table
KB0866646

SEVERE *** ERROR *** Unknown credential type downloaded; MID server may not have access to credentials table


1983 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

MID server giving below errors during credential reload 

2020-01-28 07:11:24 (351) Worker-Interactive:Shazzam-abd9117e1be6c8909f5bfe60cd4bcb88 SEVERE *** ERROR *** Unknown credential type downloaded; MID server may not have access to credentials table
2020-01-28 07:11:24 (351) Worker-Interactive:Shazzam-abd9117e1be6c8909f5bfe60cd4bcb88 Credentials from instance loaded

Release

Any

Cause

'Type' field for a record on the discovery_credentials table is not present.

For Eg:

"Twilio Direct Auto Generated" credential should be set to "Basic Auth" but it will be empty. It is not possible to delete this record from the UI action of both form and list view.

Resolution

This record generally does not cause an issue with discovery of other devices as such. 

But if you encounter a scenario where this record is suspected to be the cause of a failed discovery or credential not being picked up by the MID server and would like this to be deleted, then you may use 'Table Cleanup' under 'System Maintenance' to remove this record.

Steps:

1. Create a new record under Table Cleanup module for table 'discovery_credentials'

2. Give the filter conditions as 'sys_id' IS 'fee0097e1be6c8909f5bfe60cd4bdc11' (where 'fee0097e1be6c8909f5bfe60cd4bdc11' is the sys_id for the credential record with NULL type value)

3. Age in Seconds is '1' and Save the record.

4. Go to sys_trigger table and open 'Table Cleaner' record and hit 'Execute Now'

Alternatively, you can also use a background script to remove the record or add a type value to this record.


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