Issue
Symptoms
On a Visual task board which was built based on "state" field ("guided board"), when user moves the card from "In progress" lane to "Resolved" lane, system opens up the card with the message "A UI Policy has prevented you from making a change" as shown in the below screenshot,
Release
Any release
Cause
There are UI policies setup on the "Incident" form with condition checks for state change and accordingly it sets certain fields on the form as mandatory, hence these UI policies are blocking the record from moving to "Resolved" lane as the fields like resolution details, code, etc are not yet filled-in, but they were made mandatory.
Resolution
Before changing the lane, fill-in the mandatory fields or customize the UI policies as per your business needs with Visual Task Board so that UI policy doesn't restrict the card.