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Business Rules on "sys_user_has_role" table does not run - Support and Troubleshooting
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KB0679456

Business Rules on "sys_user_has_role" table does not run


1977 Views Last updated : Aug 18, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Business Rules on the [sys_user_has_role] table don't run when a user is added to a group.

Release

All releases

Cause

The Contextual Security: Role Management V2 plugin changes the way role management is done. The application code handles the user being added to the group and adds the appropriate sys_user_has_role records. As this is done at a lower level, business rules aren't triggered for the sys_user_has_role inserts.

A business rule on the sys_user_has role table is not triggered when a user is added to a group but is triggered when a direct insertion is done on sys_user_has_role.

Resolution

A possible workaround can be to add the BR on either the sys_user (after Insert/update) or sys_user_grmember which will go through the roles of the user. Or, a scheduled job can be used as another workaround to look at recent changes to sys_user_has_role and perform the actions based on that.


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